Сайт учителя информатики Насоновой Н.А.
Четверг, 13.12.2018, 23:05
Вы вошли как Гость | Группа "Гости"Приветствую Вас Гость | RSS
 
Главная зад19Мой профильРегистрацияВыходВход
Меню сайта
Поиск
Опрос
Оцените мой сайт ?
Всего ответов: 71
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

Задание 19 подразумевает практическую работу учащихся за компьютером с использованием специального программного обеспечения – электронных таблиц. Результатом исполнения задания является отдельный файл.

Задания части 3 направлены на проверку практических навыков по работе с информацией в текстовой и табличной форме, умения проводить обработку большого массива данных с использованием средств электронной таблицы или базы данных.

Пример

После проведения олимпиады по информатике жюри олимпиады внесло результаты всех участников олимпиады в электронную таблицу. На рисунке приведены первые строки получившейся таблицы:

 

A

B

C

D

E

F

G

1

Фамилия

Имя

Класс

Зад. 1

Зад. 2

Зад. 3

Зад. 4

2

Корнеев

Сергей

9

7

10

4

9

3

Васильев

Игорь

9

0

7

5

3

4

Лебедев

Николай

8

3

7

0

2

 

В столбце A электронной таблицы записана фамилия участника, в столбце B — имя участника, в столбце C — класс, в котором учится участник (в олимпиаде принимали участие только учащиеся 8 и 9 классов), в столбцах D, E, F и G — оценки каждого участника по четырём задачам, предлагавшимся на олимпиаде. Всего в электронную таблицу были занесены результаты 1000 участников.

По данным результатам жюри хочет определить победителя и лучших участников олимпиады. Победитель и лучшие участники определяются по сумме набранных баллов по всем задачам (чем больше сумма баллов, тем выше участник стоит в таблице), при этом результаты учащихся 8 классов умножаются на коэффициент 1,25. Если двое учащихся набрали (с учетом коэффициента) одинаковое количество баллов, то учащийся 8 класса занимает более высокое место, чем учащийся 9 класса. Например, в приведённой выше таблице Лебедев Николай, набравший 12 баллов, должен идти выше Васильева Игоря, набравшего 15 баллов, так как после домножения на коэффициент 1,25 Лебедев Николай также получит 15 баллов в сумме, а при равных баллах учащиеся 8 класса получают более высокое место.

Выполните задание

Откройте файл с данной электронной таблицей (расположение файла вам сообщат организаторы экзамена). После этого подсчитайте для каждого участника сумму его баллов, домножив результаты учащихся 8 класса на коэффициент 1,25. После этого отсортируйте данную таблицу в порядке уменьшения суммы баллов, полученных учащимися, при равной сумме баллов учащиеся 8 класса должны идти выше учащихся 9 класса. При этом первая строка таблицы, содержащая заголовки столбцов, должна остаться на своём месте. Полученную таблицу необходимо сохранить в каталоге под именем, указанным организаторами экзамена.

Особенности задания 19

Таблица содержит большое количество записей и требуют навыков работы с большими массивами данных.

Быстрое перемещение по таблице:

  • Ctrl+Home – в начало;
  • Ctrl+End – конец;
  • Shift+F5 – в место последних исправлений.

При решении задачи 19 можно использовать функции:

1.      Если в условии задачи необходимо найти количество чего-либо, то используем функцию СЧЁТЕСЛИ(диапазон; критерий)

Например,

Светлана Сидорова собиралась полететь на каникулах на отдых и записала расписание перелётов из Москвы в разные города в виде таблицы. Ниже приведены первые пять строк таблицы.

 

А

B

C

1

Город

Страна

Примерное время  в пути

2

Абакан

РОССИЯ

4

3

Абу-Даби

ОАЭ

5

4

Адлер

РОССИЯ

2

5

Акаба

ЕГИПЕТ

5

Каждая строка таблицы содержит запись об одном маршруте перелёта.

В столбце A записан город назначения, в столбце B – страна назначения; в столбце C – примерное время в пути.

Всего в электронную таблицу были занесены данные по 191 маршруту в алфавитном порядке.

Для какого количества городов расчётное время перелёта составляет более 5 часов? Ответ на этот вопрос запишите в ячейку H2 таблицы.

  • Курсор – в ячейку H2
  • =СЧЁТЕСЛИ(С2:С192; ">5")

 

2.Если в условии задачи необходимо найти процент чего-либо, то используем функции  СУММЕСЛИ(диапазон, условие, [диапазон_суммирования]),

СЧЁТЕСЛИ(диапазон; критерий),

ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь]) и пр.
Например,

Какой процент от всех 6-часовых перелетов составляют 6-часовые перелёты в города России? Ответ на этот вопрос в виде целого числа нужно записать в ячейку H3 таблицы.

  • Курсор – в ячейку H3
  • Подсчитаем все 6-часовые перелеты и запишем в любую ячейку, например, Е2

=СЧЁТЕСЛИ(С2:С192; 6)

  • Подсчитаем все 6-часовые перелеты в города России
    • Для этого в ячейку D2 запишем

=ЕСЛИ(В2="РОССИЯ"; 1; 0)

  • Скопируем формулу во все ячейки до В192
  • Посчитаем все 6-часовые перелеты и запишем в любую свободную ячейку, например, Е3      

=СУММЕСЛИ(С2:С192; 6; В2:В192)

  • В ячейку Н3 запишем формулу нахождения процента от всех 6-часовых перелетов составляют 6-часовые перелёты в города России (меньшее число делим на большее! и устанавливаем процентный формат на эту ячейку)
    • =Е3/Е2
  1. Если в задании необходимо проверить одновременное выполнение двух условий, то можно использовать функции
ЕСЛИ(лог_выражение; [значение_если_истина]; [значение_если_ложь]) 
И(логическое_значение1, [логическое_значение2], ...) 

 

Например,

В электронную таблицу занесли данные о калорийности продуктов. Ниже приведены первые пять строк таблицы.

 

А

В

С

D

Е

1

Продукт

Жиры, г

Белки, г

Углеводы, г

Калорийность, Ккал

2

Арахис

45,2

26,3

9,9

552

3

Арахис жареный

52

26

13,4

626

4

Горох отварной

0,8

10,5

20,4

130

5

Горошек зелёный

0,2

5

8,3

55

 

Всего в электронную таблицу были занесены данные по 1000 продуктам.

Сколько продуктов в таблице содержат меньше 25 г жиров и меньше 25 г углеводов? Запишите число этих продуктов в ячейку H2 таблицы.

  • Курсор – в ячейку F2
  • Проверим выполнение сразу двух условий (для этого если оба условия выполняются, то в ячейке появится 1, иначе – 0)   =ЕСЛИ(И(В2<25;D2<25);1;0)
  • В ячейку Н2 запишем функцию, которая просуммирует все полученные 1 =СУММ(F2:F1001)

4.Если в задаче необходимо найти среднее чего-либо, то используем функции СУММЕСЛИ(диапазон, условие, [диапазон_суммирования]),

СЧЁТЕСЛИ(диапазон; критерий),

Например,

Какова средняя калорийность продуктов с содержанием белков менее 1 г? Ответ на этот вопрос запишите в ячейку H3 таблицы с точностью не менее двух знаков после запятой.

  • Посчитаем калорийность при количестве белка<1 и запишем в отдельной ячейке, например J2:

=СЧЁТЕСЛИ(B2:B1001;"<1")

  • Тогда в H3 для определения средней калорийности продуктов с содержанием белков менее 1 г запишем:

=СУММЕСЛИ(B2:B1001;"<1";E2:E1001)/2

Вход на сайт
Безопасность

Банк сайтов
Банк Интернет-портфолио учителей
...
Презентации PowerPoint
...
Сайт добавлен в каталог образовательных сайтов на портале "Банк Интернет-портфолио учителей"
Друзья сайта
  • Создать сайт
  • Официальный блог
  • Сообщество uCoz
  • FAQ по системе
  • Инструкции для uCoz
  • Copyright MyCorp © 2018
    Создать бесплатный сайт с uCoz